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Warranty 
The software libraries and tools are provided "as is" without warranty. The entire risk for the results and 
performance of these libraries and tools is assumed by the purchaser. Intec Automation Inc. does not 
warrant, guarantee or make any representation regarding the use of this product. 

No other warranties are made, expressly or implied, including, but not limited to, the implied warranties of 
merchantability and suitability of products for a particular purpose. In no event will Intec Automation Inc. 
be held liable for additional damages, including lost profits, lost savings or other incidental or 
consequential damages arising from the use or inability to use Intec's products or the products resold by 
Intec. 

 

Disclaimers 
Intec Automation Inc. reserves the right to make changes without notice, to any product, to improve 
reliability, performance, capabilities, design or ease of use, or to reduce size or cost. 

Intec Automation Inc. products may not be used as components in life support devices of any description. 

 

Copyright 
The design of the software libraries is copyrighted, and copying part or all of the design is prohibited by 
law.   
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Introduction 

 

How to use this Manual 
New users are advised to start at the top of the documentation tree shown on the cover of this document, 
starting with the Getting Started document.  (e.g. WildFireGS.pdf), and work their way down through the 
two Quick Start documents, before reading this document.  

 

SBCTools comes in 2 Flavors 
SBCTools comes in two flavors: Direct and uClinux.  The direct SBCTools is used for developing 
applications which run directly from the dBUG monitor, where the uClinux version is for developing 
uClinux user applications1.  Although these two flavors have different targets the IDE for the most part is 
exactly the same.  This manual is split into three major sections: 

 

1. SBCTools  – Detail concepts which are shared between the two flavors. 

2. SBCTools Direct – Specifics of working with the standard version of SBCTools (A hands on 
Guide) 

3. SBCTools uClinux – Specifics of working with the uClinux version of SBCTools (A hands on 
Guide) 

                                                 
 1 SBCTools uClinux is a development tool-chain for developing applications to run on a target 

microcontroller under the uClinux kernel. It is not suitable for configuring and compiling the uClinux 
kernel which runs on a PC, under windows. 
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SBCTools Overview 

Software Modules and Licenses 
SBCTools is an integrated tool suite comprised of many individual pieces.  The majority of this software is 
open source and can be modified and used for free.   

 

Software Description License Source 

Eclipse IDE Eclipse 3.0 IDE with CDT 2.1 Tool Plug-in.  Eclipse is 
an open source project which can be found at 
http://www.eclipse.org.  Eclipse has been modified by 
Intec to better support embedded development with the 
ColdFire microprocessor family.  The unique plug-ins 
added by Intec are licensed under the Intec software 
license and are not open source.   

Eclipse Public 
License (EPL) 

and  

Intec 
Automation 
Software 
License 

Not Included 

GCC SBCTools includes two distinct versions of the GCC 
compiler.  One for bare board applications and one for 
uClinux applications.  GCC is compiled by Intec 
against the mingw libraries for stand alone execution 
on windows. 

GNU Public 
License (GPL) 

Included on 
CD only (not 
installed) 

GDB Two versions of GDB are included, one for serial 
debugging and one for TCP/IP debugging under 
uClinux with gdbserver. 

GNU Public 
License (GPL) 

Included on 
CD only (not 
installed) 

uClinux uClinux is a port of the Linux operating system to 
microprocessors without Memory Management Units 
(MMU).  uClinux has been modified and enhanced by 
Intec to support features of our products and all 
modifications are subject to the GPL. 

GNU Public 
License (GPL) 

Included on 
CD only (not 
installed) 

dBUG The dBUG monitor allows a target board to download, 
run, and debug applications on the target without the 
use of a Background Debug Module (BDM).  Intec has 
enhanced the dBUG monitor for tighter intergration 
with SBCTools.  The base dBUG source code can be 
downloaded from Freescale. 

Intec Software 
License 

Not included 

(Available 
from Intec) 

TCP/IP Stack 
(Bare board 
only) 

The TCP/IP stack for bare board applications is a port 
of the OpenTCP stack with some enhancements and 
modifications by Intec. 

OpenTCP 
License 

Included 
with install 

Run Time 
Library 
(RTL) 

The runtime library is a set of C functions which can be 
called by both bare board applications and from within 
uClinux. 

Intec Software 
License 

Not included 

(Available 
from Intec) 
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Integration 
Intec Automation has taken these various pieces of open source software and Intec proprietary tools to 
create a single integrated development environment.  The following diagram shows how each of the pieces 
of SBCTools integrate. 
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SBCTools 

SBCLauncher 
Much of SBCTools functionality2 depends on a SBC connected over the serial line, (e.g. debugging, 
flashing, running, etc).  The SBCLauncher will scan the PC COM ports for a connected SBC and 
automatically launch the IDE.  If the SBCLauncher finds a board with the dBUG monitor it will launch 
SBCTools Standard, and if the SBCLauncher finds a uClinux SBC it will launch SBCTools uClinux. 

 

 
 

1. The progress bar indicates that the SBCLauncher is busy looking for and analyzing the PC COM ports 
and the devices attached. 

2. The “details” view will display a verbose output of the tasks being performed by the SBCLauncher. 

 

                                                 
2 SBCTools can only compile and manage projects when it is offline. 
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Upon a successful scan the SBCLauncher will move to this screen. 

 

1. This box will contain each device that was discovered on the PC.  Drop down and select the device to 
work with. 

2. When a device is selected the “Board Summary” section will display data about the board. 

3. The “Options” button will provide access to two options: 

a. Launch automatically – this option is also available on the bottom of the window.  when set 
the SBCLauncher will not wait for you to select the device, but will automatically launch 
SBCTools once the scan is complete (provided one and no more than one SBC was found). 

b. Launch Quick Start – this option will launch the Quick Start for SBCTools PDF file as well as 
the SBCTools environment. 
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If the SBCLauncher fails to find any SBCs the following screen will be displayed. 

 

1. Select “Scan” to start again.  This is useful if the board was not connected, or powered up during the 
first scan.  also if there is another application running using the serial port (i.e. HyperTerminal) then 
you can close it and scan again. 

 

Warning ! uClinux can take 10 – 15 seconds to boot from the SD card, this means that the 
SBCLauncher may not detect a uClinux board that is in the process of booting, If the first scan fails 
simply try again. 

   

2. If you knowingly do not have an SBC connected to you PC, but you would simply like to manage, edit 
and compile projects you can work offline.  Simply pick whether you would like to work under the 
Standard environment or uClinux and then press “Work Offline” button. 
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Basic Concepts 

Eclipse 
Eclipse is a powerful open source Integrated Development Environment (IDE) which is highly extensible.  
The C Development Tools (CDT) is an Eclipse plug-in which integrates the Eclipse front end with the 
GNU tools (GCC compiler, and GDB Debugger) behind the scenes.  Eclipse has many of the features that 
developers have come to expect in an integrated development environment including, but not limited to, 
syntax aware code editor, code folding, compilation and problem management, advanced project 
management with build configurations, integrated debugging, and even CVS client support.  The following 
sections will give a very brief introduction to concepts through out Eclipse, the C/C++ and Debug 
perspectives.  In addition it is highly recommended that developers make use of the help system currently 
available in the Eclipse IDE which can be accessed by going to the main menu Help -> Help Contents. 

Perspectives 
A perspective consists of a set of views in the Eclipse window, arranged to accomplish a specific task. For 
example, the Debug perspective combines views that are commonly used with debugging a program, 
whereas the C/C++ Perspective combines views which are useful for editing source code, compiling it and 
viewing and correcting the compilation errors.  Perspectives can change automatically in some cases (like 
when starting a debug session) or the developer can change the perspective manually at any time by goin to 
the  main menu Window -> Open Perspective or by using the quick access toolbar. 

 

Workspaces 
An Eclipse workspace can be any PC directory, but with a difference: It contains Eclipse projects and 
additional information associated with these projects. Any directory can be turned into a workspace by 
declaring it as such in Eclipse. 

Multiple workspaces can be useful for organizing work. For instance, two workspaces, Demo_Programs 
and WildFire_Dev could be used to separate tutorial programs from serious development programs. 
Switching workspaces is done through File  Switch Workspace… This results in Eclipse being 
terminated and then restarted in the new workspace. 

Projects 
A project is a collection of source files, makefiles and project files required to generate an executable 
program.  This collection of files are all stored in a project directory, which may or may not be physically 
in the workspace directory.  There are two ways to start working with a project, import an existing project 
(like the demo programs) or to create a new project.  Importing a project will simply add the existing 
project (leaving it where it physically exists) to the list of projects in the workspace.  In other words, 
Importing a project is not about moving files, but about setting up the links to make Eclipse aware of the 
project files. It bears noting that importing a project from a location outside the workspace will not copy 
files into the workspace.  Creating a new project will create a new folder (at a physical location specified 
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by the user) and all new files for that project will physically exist within that new folder.  A project may 
have one or more build configurations and by default include a “debug” and “release” build configuration.  
Not to be confused with the “debug” build configuration, each project will also requires one or more debug 
configurations. 

Build Configurations 
A build configuration determines the options for the build.  Typical configuration options are: include 
paths, preprocessor options and other compiler options.  Two common configurations that are generated by 
default for a new project are for Debug (containing debug information) and Release (with no debug 
information). 

Debug Configurations 
A debug configuration stores properties about a debug session.  A debug configuration is created by 
selecting Run -> Debug… on the main menu.  Each debug configuration must have a name (usually the 
project name), a project, and a debuggable binary (.elf file) within the project.  Once a debug configuration 
has been launched once, it will automatically be part of the debug history and will be available directly 
from the Run -> Debug History menu and as a drop down item on the debug toolbar icon.  

 

Preferences 
Preferences allow the developer to configure the IDE look, feel, and default functionality.  The preferences 
are remembered across IDE sessions and can even be imported and exported.  The preferences window can 
be accessed from the main menu Window -> Preferences.  Be sure to browser all the preferences and setup 
the environment the way best suits your needs. 

 

Useful Preferences 
 

• C/C++-- Debug – Default format for variables, expressions and registers (Hexadecimal is most 
useful for embedded debugging) 
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• C/C++ -- Editor – Setup content assist, code folding, appearance, syntax highlighting. 

• Workbench – Setup Generic workbench settings such as opening files with a single or double 
click. 
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SBC View 

The SBC View provides interactive console access to the SBC.  Action on the SBC menu are executed via 
the SBCView by sending, receiving and parsing text.  You can access the SBCView by going to the main 
menu Window -> Show View (Select “Other…” if SBC View is not directly available).  

 

 
 

Type characters into the bottom box and view the output in the big window.  A clear action is also available 
from the icon in the top right corner or by right clicking anywhere in the SBC View.  The SBC view can be 
used to interact with uClinux and the dBUG monitor. 
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C/C++ Perspective 
The C/C++ perspective is the most useful perspective for developing and maintaining projects and code.  
The editor provides highly integrated C code editing, the console shows the low level interaction with 
GCC, the problems view displays compiler warning and errors, and the outline view is a tree view of all 
code constructs including variables, types, functions, etc.  The following views can be accessed in the 
C/C++ Perspective by going to Window -> Show View. 

Editor 
The C editor will be invoked for any C file type (.c, .h, etc.).  The following Features make C code editing 
easy and efficient. 

 

• Syntax Highlighting – Key words are bold, comments are green, and strings are blue.  These colors 
and settings are also configurable in preferences. 

• Code Folding – Functions, structures, and even comments can be collapsed and expanded in place. 

• Code Completion – A very useful feature invoked automatically by triggers such as “.”, “->”, but 
can also be invoked manually at any time with Ctrl + Space.   
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Console 
The console is the eye into the GCC compiler backend.  The console displays the output of and commands 
invoked automatically in the background as a result of actions taken in the IDE.  Use the console to 
diagnose low-level problems and see more verbose output from the compiler. 

 

 

Problems 
“Problems” is Eclipse’s term for what are normally called errors.  

The problems view is a parsed and context sensitive view of the compiler output.  Problems are listed with 
icons and can be double clicked to go directly to the line of the error or warning.  Problems can be filtered 
and sorted by right-clicking anywhere in the view or by using the quick access toolbar buttons in the top 
right corner. 

 

   
 

Information: It is useful to filter “path entry problems” as this version of SBCTools does not support 
automatic path detection and will therefore often produce warnings. 
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Outline 
The outline view shows a birds eye perspective of structural elements in the current file.  In this view 
variables can be refactored (renamed), breakpoints and watch points can be inserted, etc.  
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Debug Perspective 
The debug perspective, as its name suggests, is best suited for debugging sessions.  This perspective 
provides views for control (stepping, breakpoints, etc.), viewing registers and memory, defining 
expressions, source and disassembly.  The following debug views should be on the screen by default, but 
can also be accessed by selecting Window -> Show View from the main menu. 

Debug Control 
Debug sessions can be controlled by the keyboard or from the “Debug” view.  The options available 
include: 

 

•   resume program execution until next breakpoint. 

•   terminate debugger (remote process will not terminate if running, a hard reset will be 
required). 

•   Restart program from the beginning (will not clear variables just change program counter) 

•   Step into a function 

•   Step over a function call 

•   Step out of the current function 

•   Instruction stepping mode (Step at source level or step at disassembly level) 

 

 
 
The stack frame is displayed in a tree view and can be traced back through the source code by clicking on 
the items.   

Attaching external source 
When stepping through source code you may want to step into a function which does not have a source 
code module within your project directly.  The debugger will allow you to attach external source code to 
your session and step through it.  This will automatically happen when stepping into functions that have 
debugging information but no source code.  Use the browse button to select the location of the source code 
you would like to step into. 
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Registers 
During a debugging session it is often useful to view the values in the CPU registers (especially if 
debugging at the disassembly level).  The registers view displays and allows modification of the CPU 
internal registers. 
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Memory 
Inspecting and editing memory can be achieved via the memory view.  Memory can be formatted in single, 
or multiple byte chunks with 1,2,4,8, or 16 columns.  Editing memory is done by directly typing into the 
memory view (one nybble at a time).  Check out all of the options available by right-clicking anywhere in 
the memory view. 

 

 

Variables 
Local variables show up automatically in the Variables view when the are in scope. If a value changes as a 
result of a debugger operation (i.e., step), it shows up in red. 

 

 
Local variables show up automatically. 
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To modify a variable, double-click on it and modify it in the edit box that appears: 

 

 
 

The Variables view is particularly useful for inspecting and modifying complex structures, even down to 
the bit-field level: 

 

 
 

Global variables can be added to the Variables view by right-clicking in the Variables view  Add Global 
Variables… 
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…and selecting the global variable from a pick-list of all the global variables in the project: 

 

 
 

Expressions 
Expressions can be evaluated and monitored in the Expressions view. There are several ways of viewing 
expressions.  To view an expression that already exists in the source code, select the expression (without 
the ‘;’) and right-click  Add Watch Expression… and click OK in the variable display box. 
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… and click OK in the variable display box. 

 

 
 

Warning!  An illegal expression, can cause a processor exception on the target. 

 

If the “Expressions” view is not visible, it can be made visible through Window  Show View  
Expressions: 
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Mouse Over 
Variables can be conveniently inspected at any time by placing the cursor over the corresponding symbol in 
the source code view: 

 

 
 

Disassembly 
Disassembly debugging can be very useful for embedded systems, as execution can be controlled at the 
lowest level.  To view and step through the disassembly code select Window -> Show View -
>Disassembly.  To step at disassembly level be sure to change the instruction stepping mode which can be 

toggled from source to disassembly by clicking the    button in the debug control window.  When in 
instruction stepping mode is on each step will move only one assembly instruction. 

 

 

SBCToolsUM.doc 20 2-Sep-05 



 

Additional Features 
The previous sections have outlined the features of the IDE that are required for working with SBCs and 
developing embedded applications.  The next sections describe other useful features which are available, 
but not required for developing embedded C applications. 

CVS 
The Concurrent Versioning System (CVS) is a version control system which many software developers use 
for helping manage team projects.  Eclipse includes a very feature rich and functional CVS client plug-in.  
The CVS client can checkout, update, commit, compare, and more.  CVS features can be accessed from the 
CVS Repository Exploring perspective and the Team Synchronizing perspective.  Select Window -> Open 
Perspective -> CVS Repository Exploring or Team Synchronizing.  First Thing to do when working 
with CVS is to specify a working CVS repository. 

 

 
 

For more information on setting up CVS within Eclipse see the Help- > Help Contents -> Workbench User 
Guide -> Getting started -> Team CVS Tutorial. 

Help and Tutorials 
In addition to this manual there is an extensive integrated help and tutorial system within Eclipse.  Help can 
be accessed from the Help -> Help Contents on the main menu.  See Help -> Welcome to access the 
welcome screen which also contains links to the help system. 
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Using SBCTools Direct 
In addition to the concepts mentioned above SBCTools Direct adds the following features which are 
accessible from the SBC main menu and or the toolbar buttons available in the C/C++ Perspective. 

Resetting the SBC 

 
There are many reasons why it will be desirable to reset the SBC (such as clearing SDRAM, initializing 
hardware to defaults, endless loop).  A software reset will execute all startup code and put the SBC back 
into its default state.  A software reset with this button will only work if the dBUG monitor is currently in 
control of the board.  The dBUG monitor will loose control of the board when a user application is running.  
In the case that a user application is running a “hard reset” will be required.  A hard reset can always be 
accomplished by power cycling the board, but often there will be an easier way such as a push button or 
reset pads.   

Editing board properties 

  
View and edit board properties including IP information, Autorun, Watchdog, and RTC. 
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1. Network Settings – Should be configured for your network (If using TCP/IP library without DHCP 
these settings will be used) 

2. Boot-up Settings 

a. Autorun – If “on” the dBUG monitor will automatically load a program from either SD card 
or external flash and run it.  If “off” dBUG monitor will always boot to the “dBUG>” prompt. 

b. Watchdog – If “on” the dBUG monitor will leave the watchdog enabled after reset and service 
it periodically such that it doesn’t time out and reset the board.  Once dBUG passes control to 
a program it is the responsibility of that program to service the watchdog or disable it. 

Creating a new project 

 
A project is required for generating an executable to run on the target SBC.  To create a new project select 
File -> New -> Managed Make C Project (C++ is not currently supported with SBCTools). 

 

 
 

Type in a project name and select Finish.  You now have an empty project, before you can do anything you 
will need to create at least one source file to contain your main function.  You can do this by selecting your 
new project in the C/C++ Projects View, right clicking and selecting New -> C Source File. 
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Name the source file appropriately (main.c) and select Finish. 

 

 
 

You now have an empty C source file and you must add your main function and any other functionality 
from there. 
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Compiling a Project 

 
Once the main function is created the project can be compiled into an executable format.  To compile the 
project select the project in the C/C++ Projects view and right click and select Rebuild Project. 

 

 
 

Selecting Rebuild will compile every source file regardless of changes where selecting Build will only 
build changed files.  View the Console output and the problems view for compiler errors and warnings.  
Once you project is free of errors it will generate an executable.  You will know the executable has been 
created by looking at the Project tree view. 
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Running a program 

 
To run the newly created program it will need to be downloaded to the target SBC and executed.  This can 
be done by using the special SBC “Download/Run” command.  Select SBC -> Download/Run. 
 

 
 
A dialog will open and ask for a container (folder) that contains the “elf” file.  Select the folder (In this case 
the release build) and press ”OK”.  this will start downloading your program (can take from 10 seconds up 
to minutes depending on the size of your program).  The SBC view will display the output of you program 
once it has been downloaded. 
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Debugging a program 

 
Before debugging you will need to ensure your project is built with debug information.  By default the 
“Debug” build configuration will build with debugging information included and optimization off (which 
sometimes interferes with debugging).  To build the debug version of your project select your project in the 
C/C++ Projects view, right click and select Properties.  From the Properties dialog select Debug from the 
build configuration drop down box and press OK.  Now rebuild your project again. 

 

 
 

To debug a program, a debug configuration must first be created.  To create a debug configuration first 
select your project in the C/C++ Projects view and then select Run -> Debug… from the main menu.  
From the Debug configuration screen select ColdFire Serial Debugger and then select the “New” button. 
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This will create a valid debug configuration for you project.  Now fill in the application executable to 
debug by selecting Search… and be sure to select the debug version of you application and click OK. 
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Press “Debug” to start a debug session.  A debug session (like running a program) will have to download 
the binary code to the remote system and therefore may take some time.  Once it is finished downloading 
the view will switch to the Debug Perspective and your debugging session is ready to go. 

Deploying a program 

     - External flash (non-removable) 

     - Removable flash (SD Card, MMC, Compact Flash, etc) 

Once a program has been finalized and debugged you may wish to save to program the permanent storage 
on the SBC.  Once in the SBC permanent storage the program can be run manually or automatically when 
the board boots up (Autorun in board parameters).  Like running a program, saving to flash will require the 
program to be downloaded to the board.   

Save 
To save a program to flash select SBC from the main menu and then select Save Program (either External 
flash or SD Card).  The next dialog will ask for a file to save (.elf), select the file and press OK.  In the SBC 
view you will see the file being downloaded and a message will be shown indicating whether the save was 
successful. 
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Load and Run 
To load and run a program from the flash select SBC from the main menu and select Load Program 
(either External flash or SD Card).  The next dialog will ask for a file to save (.elf), select the file and press 
OK.  In the SBC view you will see your program run.  

 

 
 

Delete 
To delete a program from the flash select SBC from the main menu and select Delete Program (either 
External flash or SD Card).  The next dialog will ask for a file to save (.elf), select the file and press OK.  
In the SBC view you will see a message indicating whether the deletion was successful. 
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SBCTools and P&E Source Level Debugging 
P&E’s ICDCFz is a powerful debugging tool for stepping through assembly code and accessing registers 
and memory directly.  It also supports source level debugging.  However, ICDCFz only recognizes source 
files that are located in a subdirectory in the project.  To ensure that the ICDCFz will find the source code 
of the user program, two rules must be followed:   

• All source files must be located in a folder within the root directory of the project.   

• All folders containing source files must have their paths included in the project properties.   

New SBCTools projects that support ICDCFz debugging will follow these rules. However, existing 
SBCTools projects that were not developed for ICDCFz debugging will have to be modified to incorporate 
these rules: 

1. Move all source files into a subdirectory: 

2. Switch to the C/C++ Projects view by selecting Window  Show View  C/C++ Projects. 

3. Create a directory in the root of the project (called “ICDCFZDebugging” in this example).  Right-click 
on the root of the project and select New  Folder. 
 

 
 

a. The “New Folder” dialog opens, prompting to enter a name for the new folder.  Enter a descriptive 
name (“Src” in this example).  
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b. The new folder appears in the C/C++ Projects view.  
 

 
 
 

c. Select all source files and folders containing source files that are in the root of the project.  Multi-
select items by holding the <Ctrl> key while clicking on the files and folders.   
 

 
 
 

d. Right-click on one of the highlighted items and select Move…  
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A “Folder Selection” dialog opens to select the destination folder.   
 

e. Select the newly created directory (“Src” in this example) as the destination, and click OK.   
 

 
 
Now all files and folders have been moved into a folder contained in the root.  Many of the paths 
in the project have changed and need to be updated.   
 

4. Update the paths in the project properties so that the compiler and ICDCFz can find the source files.   
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a. Right-click on the project (“ICDCFZDebugging” in this example) in the C/C++ Projects view 
and select Properties.   
 

 
 
 
The “Properties for …” dialog opens for the selected project. 
 

b. Click on C/C++ Build in the left hand pane.   
 

 
 

c. Select “C Compiler”  “Directories” from the “Configuration settings”. 
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A list of the included paths appears in the “Include Paths” pane.   
 

d. Click on the  Add icon in the Toolbar to add an include path.  The “Enter Value” dialog 
appears.  Enter the path to the new folder in the dialog and click OK.   
 

 
 
Repeat the preceding step for each subdirectory contained in the new folder. 
 

e. Modify existing paths to match the new locations.   
 

 
 
 

f. Click OK to the “Properties for …” dialog and return to the C/C++ Projects view.   
 
The project is now ready to be compiled by SBCTools and debugged using ICDCFz.   
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Using ICDCFz (P&E BDM Debugger) 
Once a program has been compiled for ICDCFz source level debugging it can be run with the P&E 
debugger: 

1. Run ICDCFz from the Windows Start menu or double-click on the  icon on the desktop. 

2. Click  Play Macro icon on the Toolbar or click File  Play Macro. 

 

 
 

3. Browse to the where the debug version of the elf file is stored and select “startup.icd”.  In this 
example it is “C:\SBCTools\eclipse\workspace\ICDCFZDebugging\Debug” directory.  If the 
“startup.icd” file does not appear here, a copy from the “<install_path>\eclipse” directory will have 
to be placed in the “C:\SBCTools\eclipse\workspace\ICDCFZDebugging\Debug” directory. 

 

 
 

ICDCFz will execute the commands in the “startup.icd” macro file until it reaches a command to load 
a file. 
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4. A “Specify Object/Debug File to Load” dialog appears.  Select the elf file to be debugged and press 
OK.  In this example it is “ICDCFZDebugging.elf”. 

 
 
ICDCFz will load the file, start executing the program and stop at the program’s main function.  The 
source code will be visible in “Code Window 2”.  

5. Use the ICDCFz high level commands for stepping , running  and setting breakpoints in the 
program.   
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Using SBCTools uClinux 
 

Development with uClinux 
Developing uClinux applications with SBCTools requires a TCP/IP connection, Windows file sharing, and 
of course uClinux running on the target SBC.  Compiled applications are transferred from the SBCTools 
workspace to the SBC over the network using file sharing protocols.  The SBCTools workspace can be 
seen as another directory from the SBC running uClinux.  Running an application from the SBCTools 
workspace is as simple as issuing the application name at the command line on the SBC.  The following 
diagram depicts the workspace and SBCTools integration when setup with SBCTools. 

 
 

Be sure to also checkout the Programmer Reference for information on programming and using uClinux. 

TCP/IP Networking 
In order for file sharing to work, TCP/IP networking must be setup between the host and the target SBC.  
By default uClinux is shipped with a DHCP client running.  On bootup the DHCP client will probe the 
local network for a DHCP server and attempt to retrieve and IP address.  In the uncommon situation there 
is not a DHCP server on your network you will be required to setup the IP address manually.  The IP 
address can be set manually by editing the uClinux properties which is covered in the following section 
Editing uClinux Properties. 
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Samba file sharing 

 
uClinux includes a file sharing client called a Samba client.  Samba file sharing is compatible with 
windows file sharing which means files on windows can be swapped with those on uClinux.  SBCTools 
provides an action which will automatically map your shared SBCTools workspace to a directory on the 
uClinux SBC.  Before this will work your SBCTools workspace must be a shared folder with the share 
name “SBCToolsWS”.  If you do not have your workspace shared SBCTools will detect that and ask you 
to share it before continuing.  In order for your workspace to be correctly mapped you will need to enter in 
your PC password as this is required for connecting from another computer.  If you do not use a password 
you may leave the dialog blank and press OK.  See “Appendix A: Windows File Sharing” for more 
information on mapping your workspace. 

 

 
 

You will receive warning messages, but as long as there are no “errors” the connection will complete 
successfully.  session request to xxx.xxx.xxx.xxx failed is not a fatal error and can be safely ignored. 

 

 
 

Once your workspace is shared this directory can be used for transferring files to your  

Shutdown 

  - Shutdown uClinux -  (hang) requires hard reset to revive. 
 

 - Reboot uClinux – shuts down and then performs a software reset  
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Shutting uClinux down correctly is very important.  A shutdown procedure ensures that all data that is in 
RAM is flushed to disk before RAM contents is destroyed.  The shutdown option or reboot option should 
always be executed before de-powering the board. 

 

 
 

A successful shutdown will produce the above output, notably “System halted” indicates that it is now safe 
to de-power the board.  

Editing uClinux properties 

 
 
uClinux properties such as IP address, background services, and startup services are all typically executed 
as applications or command from the command line.  To automate this process such that a user is not 
required to execute these commands every time they boot the system, uClinux implements an “rc” file.  The 
“rc” file is executed as a script before the uClinux shell is invoked on startup.  To make it easy for users to 
work with an “rc” file the uClinux property editor can generate and download the file automatically.  The 
following describes in detail the uClinux property editor. 
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1. Network Settings – If you would like to use a DHCP server for automatically getting you IP address 

then select this option.  Otherwise you may specify a unique static IP address, Subnet mask, and 
Default Gateway.  If you are unsure of how to specify these settings see your network administrator. 

 

2. Autorun Program – This setting will be useful when deploying a finished product.  You can specify the 
uClinux root relative path to the application you would like to run when uClinux boots.  If you wish to 
launch your program in the background such that you always have access to the uClinux shell then 
select “Launch in background” option. 

 

3. RC File Extras – Here you can enter any more uClinux commands which you would like to add to 
your boot up procedure.  again this would be useful at deployment time.  Beware of commands which 
take a lot of time and run in the foreground as they may cause you uClinux on the SBC to boot slowly 
or incorrectly. 
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4. Preview - After pressing the “Next >” button you will be able to preview the exact format of the 

uClinux “rc“ file.  This rc file will be saved to the root of your workspace if Finish is selected.  You 
will then be prompted by SBCTools to Apply the settings permanently.  If you choose “yes” then the 
rc file will be copied to /etc/rc on your microcontroller with a backup of what is currently there being 
saved to /etc/rc.bak and uClinux will be rebooted so the new settings can take effect.  If you choose 
“No” then the IP settings will be applied immediately and will only be in affect until the board is 
rebooted.  
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Creating a new project 
A project is required for generating an executable to run on the target SBC.  To create a new project select 
File -> New -> Managed Make C Project (C++ is not currently supported with SBCTools). 

 

 
 

Important! For uClinux development with file sharing all projects must be physically located in the 
workspace.  This is because the remote SBC will be running files from the workspace over the network. 

 

Type in a project name and select Finish.  You now have an empty project, before you can do anything you 
will need to create at least one source file to contain your main function.  You can do this by selecting your 
new project in the C/C++ Projects View, right clicking and selecting New -> C Source File. 
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Name the source file appropriately (main.c) and select Finish. 

 

 
 

You now have an empty C source file and you must add your main function and any other functionality 
from there. 
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Compiling a Project 

 
Once the main function is created the project can be compiled into an executable format.  To compile the 
project select the project in the C/C++ Projects view and right click and select Rebuild Project. 

 

 
 

Selecting Rebuild will compile every source file regardless of changes where selecting Build will only 
build changed files.  View the Console output and the problems view for compiler errors and warnings.  
Once you project is free of errors it will generate an executable.  You will know the executable has been 
created by looking at the Project tree view. 
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Running a program 

 
To run the newly created program the file can simply be executed at the uClinux command line in the 
mapped workspace directory.  The “Run” action under SBC -> Run will simply execute the command for 
the application you specify. 
 

 
 
A dialog will open and ask for a container (folder) that contains the “elf” file.  Select the folder (In this case 
the release build) and press ”OK”.  this will start downloading your program (can take from 10 seconds up 
to minutes depending on the size of your program).  The SBC view will display the output of you program 
once it has been downloaded. 
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Running a CGI program 

 
A CGI program is a program which is invoked by a web server and should produce HTML output to 
display into a web browser.  CGI on uClinux works with the “Boa” web server.  A CGI program can be 
written in C and the executable produced must reside in the /home/httpd/cgi-bin directory.  SBCTools has 
the added feature of being able to run a CGI program automatically by copying it from the mapped 
workspace to the cgi-bin directory and then automatically launching a web browser with the correct URL to 
invoke the CGI program.  See the uDmoWebCGI for an example of a CGI program under uClinux. 

Debugging a program 

 
Before debugging you will need to ensure your project is built with debug information.  By default the 
“Debug” build configuration will build with debugging information included and optimization off (which 
sometimes interferes with debugging).  To build the debug version of your project select your project in the 
C/C++ Projects view, right click and select Properties.  From the Properties dialog select Debug from the 
build configuration drop down box and press OK.  Now rebuild your project again. 
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To debug a program, a debug configuration must first be created.  To create a debug configuration first 
select your project in the C/C++ Projects view and then select Run -> Debug… from the main menu.  
From the Debug configuration screen select uClinux GDBServer Debugger and then select the “New” 
button. 

 

 
 

This will create a valid debug configuration for you project.  Now fill in the application executable to 
debug by selecting Search… and be sure to select the debug version of you application and click OK. 
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Press “Debug” to start a debug session.  A debug session (like running a program) will have to download 
the binary code to the remote system and therefore may take some time.  Once it is finished downloading 
the view will switch to the Debug Perspective and your debugging session is ready to go. 

Deploying a program 
Deploying a program under uClinux  is very simple and does not have any associated action.  To make the 
program resident on the external flash or the SD card you simply need to copy it from your workspace into 
another directory.  This copy can be achieved with the “cp” command (i.e., cp /mnt/workspace/DemoAD/ 
Release/DemoAD /bin) once in place on the SD card, the app can be invoked on startup from the “rc” file, 
by another program or from a shell prompt. 
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dBUG Monitor 
 

dBUG is a program that runs on the target SBC, that interacts serially with a console or debugger program 
on the PC. It also interacts with the user program that runs on the SBC. dBUG provides a mechanism for 
downloading, running and debugging programs without a BDM pod. It also stores board parameters (such 
as the IP address); handles user program boot-up; user program interrupts, and acts as an interface for the 
user program’s console I/O.  

 

Basic concepts 
The dBUG Monitor is a versatile program that carries out a number of services and can be used in different 
ways. 

 

dBUG and Serial Console Program 
A developer can interact directly with dBUG through any serial console program such as HyperTerminal, 
using dBUG’s command line interface. That is, a developer can load, debug and run his program without 
the need of a specialized debug program. dBUG offers a rich assortment of commands. The full list of 
dBUG commands can be viewed by typing “Help” after the “dBUG>” prompt, when accessing the SBC 
through a serial console program. 
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dBUG and SBCTools 
The advantage of using SBCTools to interact serially with dBUG is that it provides a feature rich visual 
debugging environment for the user to interact with his program. It allows the user to visually step through 
the source code and it allows the user to view variables and structures in meaningful ways.  SBCTools talks 
to the dBUG monitor through gdb, giving commands to step, trace, set breakpoints, inspect memory, etc., 
as discussed earlier. 

 

dBUG and User Program  
The user program may interact with dBUG even when the user program is running: 

All interrupts are handled by dBUG monitor.  Before a user program can use an interrupt, it must register 
its interrupt handler with dBUG, be it through its <module>_init() function or through the isr_register() 
function. The hardware directs interrupts to the Vector table, which is under the control of dBUG. When an 
interrupt occurs, dBUG will look after saving and restoring the program’s context while calling the 
registered handler function. If no handler is registered for the interrupt, dBUG will use a default exception 
handler. 

Exceptions during user program execution are directed to dBUG. dBUG then saves the program’s context 
and registers, terminates the user program, restarts and then displays register information on the console. 
The user program cannot recover from exceptions. 

Often, a user program needs to interact with a serial console program on a host PC. But, dBUG needs its 
own console program on the host PC. Consequently, dBUG will interact with 2 serial consoles: The 
Primary console for debugging and the Secondary console for the user program’s serial I/O, as shown in 
Figure 1. 

When debugging, dBUG uses the target SBCs COM1 as the Primary serial connection for debugging, 
whereas the user can chose either COM2 or COM3 for the Secondary serial connection for the user 
program’s console (printf, getch..) serial I/O.  

When running the program, without debugging, dBUG still handles the user program’s console serial I/O. 
But in this case, it directs this I/O through COM1, since no console is required for debugging. 

Serial I/O that uses functions found in UART.h interacts directly with the serial ports, bypassing dBUG. 
These functions are typically used for transferring binary serial data. It should be noted that if the user 
program reinitializes COM1, dBUG will no longer be able to communicate and debugging will be 
impossible. 

Certain library functions that are shared with dBUG are actually run from the dBUG code space in the 
MCF5282’s internal flash. This is transparent to the user. 

Figure 2: dBUG Monitor 
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dBUG and Autorun 
dBUG will autorun a program on bootup if the autorun option is enabled.  For the 
wildfire the autorun option is a parameter in dBUg and for the M5208EVB the autorun 
is determined by jumper JP3 on the board.  
 
 
 
 

Using dBUG 
 

Setting dBug Parameters 
dBUG stores several parameters on the SBC that determine dBUG’s behaviour.  Resetting or repowering 
the WildFire will not affect the values of these parameters: 

Base The numeral base used by dBUG for entry and display of all numbers [16].   

Baud The baud rate shared by the SBC’s Primary and Secondary serial connection [115200]. 

 

Setting Board Parameters  
dBUG stores several parameters on the SBC that determine the SBC’s behaviour.  Resetting or repowering 
the WildFire will not affect the values of these parameters. Some of these parameters are:  

Autorun  When On, dBUG monitor will try to load a program from the SD card (if present) then from the 
external flash.  If a program is available, dBUG will automatically run it.  This option can be overridden by 
the hardware.   

Watchdog  When On, the watchdog timer is left enabled on the MCF5282 and must be fed by the 
user program or the watchdog will reset the board after 8 seconds.   

Server The IP address of a PC running a tftp server.  This setting is used for network downloads.   

Client The IP address of the WildFire board.  This is not used if DNS is enabled.   

Gateway The IP address of the gateway for the LAN that the WildFire is connected to.   

Netmask The netmask of the LAN that the WildFire is connected to.   

DNS The IP address of a DNS server, used for resolving a URL to IP address.   

Ethaddr The MAC address of the WildFire.   

Time The date time in the Real Time Clock (if option installed) format is (dd/mm/yyyy-hh:mm:ss).   

The values of these parameters can be displayed on the console screen with the “show” command. Each 
value can be individually set using the “set” command.  The “set” command takes two parameters: the 
name of the parameter and the new value of the parameter.  
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Downloading Programs 
User programs can be downloaded to the SBC via the serial connection or a network connection.   

A serial download is done using the “dl” command.  The “dl” command puts the dBUG monitor into a state 
where it waits for an s-record download of the user program.  Using HyperTerminal, click on Transfer  
Send Text File… and select the s-record to download.  dBUG stores the program starting at 0x10020000 on 
the WildFire and 0x4020000 on the M5208EVB.   

A network download is done using the “dn” command.  Before the “dn” command can be issued the dBUG 
parameters must be set correctly.  The necessary parameters are Server, Client, Gateway, Netmask, 
Filename, Filetype and Ethaddr.  Once these are set, issuing the “dl” command will download the specified 
file from the specified server IP address.   

 

Programming Flash, SD Card (WildFire only) 
The “dfl” command is used to program the permanent storage on the WildFire.  This command behaves 
exactly like the “dl” command but adds the feature of saving the downloaded program to either external 
flash or an SD card.  “dfl” takes a parameter to specify the target to save to: “xf” to be saved to the external 
flash, or “sd” to be saved to an SD card.  For example, to save a program to the external flash, a user types 
“dfl xf” presses return, then transfer the s-record as with the “dl” command.   

 

Running Programs 
A program is run using the “go” command with a start address or the “gfl” command with a source.  
Programs compiled for dBUG should always start at address 0x10020000 for the WildFire, and 
0x40020000 for the M5208EVB.   

The “gfl” command takes either “xf” (for external flash) or “sd” (for an SD card) as the source parameter, 
if using the M5208EVB there is no parameter, it will always use the on board parallel flash.  It then looks 
to the appropriate storage device and attempts to load a program from it.  If a program is present, it will 
copy it to SDRAM and run it.   

 

Killing Programs 
The “kfl” command will destroy a program stored in either external flash or serial flash.  The location is 
parameterized using “xf” for external flash, “sd” for an SD card.  If a valid program exists in the specified 
location, then it is marked as dead, and will not be run by either the Autorun feature or the gfl command.   

 

dBUG Help 
More information can be found on dBUG by typing “help” at the command prompt.  The “help” command 
lists all the dBUG commands and a description of the syntax of the command.   

 

dBUG Updates 
For the WildFire the dBUG monitor can be updated via the BDM pod and CFFlasher.  For the M5208EVB 
the dldbug command will allow a new dBUG monitor to be downloaded from the old dBUG monitor. 
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Programming Internal Flash 
(Updating dBUG with the BDM) 
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Programming Flash (updating dBUG with the BDM) 
 

Use CFFlasher to load the dBUG monitor or any program into flash. This program is available on the 
SBCTools distribution CD  Install Optional Software  Install CFflasher. Installation in the 
SBCTools root directory is convenient. 
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Once CFflasher has been installed, to program flash: 

1. First attach the BDM cable to CN8 on the WildFire, CN2 on the M5208EVB.  The BDM pod takes 
control of the ColdFire chip, so any program running will be stopped.   

2. Run CFflasher.exe by double clicking the desktop shortcut or invoking it through the Start menu. 
CFflasher main window appears as below. 
 

 
 

3. CFflasher serves a number of ColdFire processors.     

The Target Configuration dialog appears.  Select M5282EVB(CFM) or M5208EVB under the 
heading.  This selects the correct CPU settings for programming the SBC.  Select either the PE_LPT or 
PE_USB depending on your pod and then click “OK”. 
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4. Now that CFflasher is configured to flash the SBC, click Program Flash to do so.   

5. The Program Flash dialog appears.   
 

 
 
 

a. Click Filename to open a file Open dialog and browse for the .S19 file to be programmed.   

b. CFflasher can program the WildFire with an S-record or binary file.  SBCTools only generates 
.S19 files for deployment, so select the S-Record radio button.   
 

 
 

c. Ensure that the Verify after Program checkbox is selected and click Program.  
 
While CFflasher programs the ColdFire, it displays a progress bar.  If the progress bar stops 
updating, wait for the program to complete.  It may take several minutes to program a large file, 
but it will finish.  Upon completion of a successful flash of the SBC, CFflasher main dialog will 
display “xxx Bytes Written” and “xxx Bytes Verified”.   
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Windows File Sharing 
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Windows File Sharing 
 

Some computers may have the Windows file sharing protocol disabled (this is the default for Windows XP 
Service Pack 2).  In this case Windows file sharing will need to be enabled before using samba file sharing 
with SBCTools. 

 

1. Turn on Windows file sharing by right-clicking the folder to be shared  Sharing & Security  click 
on the hyperlink as shown to bypass the Network Setup Wizard.  (If you do not see this dialog, and you 
do see a dialog similar to the one in step 3, then Windows File sharing is already enabled). 

 

 
 

2. When prompted to use the wizard decline and “Just enable file sharing” 
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3. You should now see a screen similar to this. 
 

 
 

4. Click on “Share this folder on the network and “OK”. 
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